LG ipLDK | PBXs and Telephone Systems | Developer Solutions

Go Connect Server Information

Minimum Version Required:

2.4.0

Installation Notes:

To perform an installation you will need the IP address of the PBX. You will also require a TAPI License on the PBX

Directory Download:

Extensions

Advisories:


In the event that connection cannot be made to the LG telephone system, no error message is provided. Check all values (in particular IP address of PBX and Tapi license) and try again.
To check if a TAPI license is on the PBX, press Trans/PGM and then press 78 (7* on the iPECS). If a digits "2" appears in the second line of the display (ie .2...6..9....) then you have the license.

Connection Information

Type:

Tapi

Requirements:

3rd Party TAPI license

Firewall Requirements:

ipLDK - UDP: 5029

PBX Information

Architecture:

The LDK and ipLDK are very similar. The LDK can be upgraded to the ipLDK through firmware. This may require a motherboard change depending on the age of the system. The LDK/ipLDK connect to the LAN via the RJ45 socket on the motherboard.
The iPECS connects to the LAN via the network socket on the main unit. The local IP address and other network settings are set through programming

Driver Requirements:

Included

Firmware Requirements (for new installations):

ipLDK: 3.8
or later

Other Requirements:

TAPI License
(for LDK/ipLDK: -TAPI-LKEY
for iPECS: LIK-TAPI(-S)